GIMP 2.10.32-1 not opening

During January 2023, using Windows 10 Pro on PC with Nvidia GeForce graphics, GIMP 2.10.32-1 suddenly did not open to full screen. Instead the program is visible in minimised state in Taskbar and does not respond to selection of any right-click options. (I mention Nvidia graphics as I remember in earlier versions of GIMP, Nvidia graphics posed a problem, but I am not suggesting this is true now.) Assistance to overcome this problem will be very much appreciated.

Something that sometimes comes up is that the GIMP window is shown on a screen that is currently turned off or disconnected, with Windows not really getting that this screen is not present and still showing application windows there.

Could that be the issue?

Hello Michael,
Thank you for your suggestion. There is a second monitor attached to the PC. It has no power to it when not in use. I am sure GIMP has not been directed to it at any time, but it does appear in Devices and Printers. If this is the problem, can you advise what changes could be made to rectify it? This problem has only surfaced in the last few weeks and the second monitor has not been in use for quite some time.
PS: I am chuffed to be writing to Michael Schumacher! :wink:

First, is GIMP’s main window on that screen when you switch it on?

GIMP stores the window positions in a file called sessionrc in your GIMP profile directory - that is %APPDATA%\GIMP\2.10 on Windows and can be entered like this into Windows Explorer. The default position for the single image window is usually 0,0 (the upper left of an area spanning a screen, or multiple screens).

Depending on your screen layout as configured in Windows (that is, is the switched off screen to the left, right, upper or lower of your active one…?) this 0,0 might be on that switched-off screen, especially if it isn’t recognized as being off.

Yes, it is: when GIMP is opened from the shortcut, it appears on the main window in the centre of screen as usual; the usual features/plugins run through, then as it finishes, it drops to the Taskbar and is not able to be opened from there.

The monitor is No. 1 and is on the left in Display Settings (identification shows this to be true) with the switched off monitor on the right.

I have found the sessionrc file and the first section reads:

(session-info “toplevel”
(factory-entry “gimp-empty-image-window”)
(position 200 100)
(size 640 480))
(session-info “toplevel”
(factory-entry “gimp-single-image-window”)
(position 0 0)
(size 1920 1027)
(monitor 1)
(open-on-exit)
(aux-info
(left-docks-width “68”)
(right-docks-width “267”)
(maximized “no”))

Hello Michael,

When putting up the excerpt from the sessionrc file above, I noted the entry - (size 1920 1027) and checked the resolutions of the settings in the graphics card control panel. I found the main monitor’s highest resolution was 1680 x 1050 and when changing the sessionrc file to that reading GIMP opened in full screen.

I suspect this is tantamount to what you were thinking in your first post. Thank you for your advice and for answering my post! All is good now :wink:

Kind regards and happy New Year.