Disable the workspace switch indicator

Hello! Can I disable the workspace switch indicator?
Switch desktops with hotkeys switch-to-workspace-right

No, unless there’s an extension (or you write one yourself).

The workspace switching indicator shown in OP’s picture is a fairly big horizontal bar across the middle of the screen, with a rectangle indicating the now-active workspace. But what I see now (in gnome-shell 42.0) is a narrower bar along the bottom of the screen, with a dot indicating the now-active workspace. See screenshot:

I also would like this indicator to go away.

For previous versions of gnome-shell, which had the large, rectangular, bulky workspace switcher popup in the middle of the screen (formerly in vertical orientation, more recently apparently in horizontal orientation as in OP’s image), I had been using the disable-workspace-switcher-popup extension. This extension always worked until now – one had to get it updated for each new version of gnome-shell, but that was always an easy change to metadata.json.

However, now that extension no longer suppresses the workspace switcher popup. And even though the popup has become smaller and is now at the bottom of the screen, it still obscures information sometimes and (for me) serves no purpose.

@fmuellner, according to your response, the only way to make it go away is with an extension. But since your reply was to a screenshot that looks very different from the workspace switcher popup that I’m seeing now in gnome-shell 42.0, I thought I’d check that your answer is still accurate.

If it is, I guess I’ll investigate whether disable-workspace-switcher-popup should still be working (in which case, there’s a bug in Gnome and I’ll report it), or whether the extension needs to be modified or rewritten in some way.

But it would be very nice to just have a way to turn off that popop natively. For users who always use the same number of workspaces, bound to the same keys, there is no purpose to displaying the popup – it does not convey any information, because we already kinesthetically know which workspace we have just switched to.

1 Like

I agree with you, this setting would be very useful for me

Yes. The appearance changed, but not if, when and how the popup is brought up.

Thank you, @fmuellner. It looks like @1113 and I will have to figure out why the disable-workspace-switcher-popup has (apparently) stopped working on or before GNOME 42.0, then. I have started a conversation over in the extension’s bug tracker.

1 Like

Hey, have you tried the ‘just perfection’ gnome extension? If I remember correctly you can disable these popups there.

I quite like the new popovers though! Maybe try them for a while? I wonder for what reason you would want to disable them. Is it just aesthetic preference or does it in some way obstruct your preferred workflow?

Greetings :slight_smile:

I’ve created an extension that not only allows you to disable the pop-up, but also adjust its position, dimensions, colors and content, so it is possible to have small non-obstructing pop-up in Gnome 3.36 - 41 similar to the one in Gnome 42. And vice versa.
https://extensions.gnome.org/extension/4788/workspace-switcher-manager/

Update: Lawrence Zhang provided a likely explanation for why the extension stopped working – see [his comment in extension ticket #49 and further discussion there. (I’d make a link here, but for some reason Discourse prevented that, saying that I can’t link to that host – GitHub – even though my earlier comment links to exactly the same ticket.)