Builder and wxWidgets project

Hi, ALL,
I am trying as suggested to work with the Builder instead of Anjuta.

I cloned my project from GitHub. Then I started the Builder and tried to open the project by pointing to the main folder.

The project opened successfully and it even successfully identified as “Autotools” project. However, when I tried to compile it it says “Compilation fails”. When I opened the “Buuild Issues” pane all I see is “Build failed”, but there was no actual error displayed.

Please help.

Or I should just abandon the old Autotools Anjuta project and create a brand new Builder project??

Thank you.

EDIT:

This is what I see on the Terminal for the Builder session:

Do you have a minimal example or the actual project? Then its easier to look into it. If the project is compilable on the terminal it should be also buildable in GNOME Builder. You could also run Builder with verbose flags so its better identifiable what happened (gnome-builder -vvvv)

Perhaps, this could help?

The stable version on flathub does not contain jedi anymore. We use now a python language server which in case uses jedi. The reason we switched is that jedi changed their API to often. But this has nothing to do with Building Autotools projects

@MichiB ,

What version is this note for?
Maybe my distro (Gentoo) didn’t update the dependencies…

Thank you.

@gunibert ,
No, I work with my project and didn’t create a reproducer.

But I’m more curious why I don’t see an actual error(s) in the pane.

Thank you.