"bad passphrase" Where do I find this?

Greetings Dear Gnomians.
I hope this post finds you fine and well.

I am a freshman student in a bachelor’s CS program in Cairo University. I love your desktop the most and I’ve been using it ever since I installed linux.
I had an issue regarding pass phrases. I tried to sign a document, then gnome keyring asked me for my PGP key’s passphrase. Once I enter the passphrase, I get the error message bad passphrase.
How is it bad exactly? I tried opening the gpg key using the terminal, and I used the same passphrase, and it works just well.
It’s just some ordinary auto-generated 32 character long passphrase. What can possibly go wrong with this?
In order to look further into the issue, I tried searching the source code for the words “bad passphrase” but I couldn’t find anything on gitlab.
Can you guys help me find it in the code so I can finish debugging?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.