Automatic connection to the WiFi with the hidden SSID

The problem is: I have to manually connect to the hidden network every time. The enabled checkbox for automatic connection doesn’t work for me. Is this a bug or am I missing something?
Currently I use Gnome 3.36.4 on top of the latest Manjaro.

Connection Settings