Applications menu stopped working

Right after the release of Fedora 38, I upgraded my laptop and as far as I remember, the new desktop (GNOME 44) worked fine. Applications menu also started up without any problems. However, after some time - after one of the regular updates - the applications menu disappeared and now - several other updates later - it still hasn’t come back.
When I open the page Installed Extensions - GNOME Shell Extensions in my Firefox browser I see that applications menu is installed but is marked with a red cross.
The menu worked so I am sure that all the necessary other requirements are installed (or at least were installed after the upgrade from F37->F38).
My question is how can I determine why applications menu no longer starts up?


PS. Last saturday I upgraded another machine from F34->F38 and on that laptop applications menu functions well so I can’t imagine that there is a bug in the menu itself.

The Extensions app shows some more error information:

An extension in the app with error state. The error details appear underneath the extension name

If you copy that information here, we may be able to figure out what’s wrong :slight_smile:

It took some time to figure out how to use flatpak / install flatpak applications but after installing the Extensions App and opening that app in the Gnome desktop, I saw that extensions were disabled. After enabling, the applications menu showed up!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.