About fonts available and messy characters?

I’m using Meld3 3.20.4 on Windows 10.

When I opened a git folder containing Chinese text, the Chinese characters cannot be displayed, but as unicode numbered squares. That seems to be because of no available Chinese fonts in my Meld3, though my OS contains them.

Besides there is the google opensource fonts supporting many languages characters.

I found some folders related to fonts configuration, under the installation folder of Meld3 at C: drive Program Files (x86) directory, with many related files, and many sections inside. How to tuning the configuration for fonts loading and correct Chinese text display?

Any help is pleased.

I believe that you’re probably seeing this bug: https://gitlab.gnome.org/GNOME/meld/-/issues/445

Unfortunately, while this has been fixed in the current unstable series, there’s no stable release available yet. You may be able to work around the problem by setting the PANGOCAIRO_BACKEND=fontconfig environment variable as mentioned in that bug report, but I haven’t tested that on 3.20.4.

Umm, just solved.

I remembered I had solved that problem on another computer in the past.

I have to select a font for the editor.
Open the Preference window, uncheck “… system fixed width font”, click the button right to “Editor font”, and select a Chinese font.

the Google open source font could be added to Meld3 and used as default. It’s said that it supports many languages characters.